در این مقاله راه اندازی Web Analyzer در IBSng ( Centos) می پردازیم بر فرض اینکه که کاربر ها بر روی روتر میکروتیک می باشند.

مثال :

رنج IP کاربران ما ۱۹۲.۱۶۸.۵۰.۰/۲۴ هست و IP اکانتینگ IBSng 192.168.0.29

در میکروتیک

ابتدا نوشتن یک منگل برای مارک کردن بسته های وب در میکروتیک

/ip firewall mangle
add action=mark-routing chain=prerouting dst-port=80 new-routing-mark=Cache passthrough=yes protocol=tcp
add action=mark-routing chain=prerouting src-port=80 new-routing-mark=Cache passthrough=yes protocol=tcp

رنج IP کاربران و اکانتینگ رو در NAT قرار میدیدم

/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.0.29
add action=masquerade chain=srcnat src-address=192.168.50.0/24

نکته :

ترافیک وب سایت ها رو از حالت نت در بیارید

/ip firewall nat
add action=accept chain=srcnat disabled=no dst-port=80 protocol=tcp src-address=192.168.50.0/24

روت کردن ترافیک ارسالی به IBSng در میکروتیک

/ip route
add  distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.29 routing-mark=Cache 

در IBSng ( Centos)

ابتدا بسته اسکوید رو نصب کنید

yum install squid
chkconfig squid on

اعمال قوانین بر روی iptables لینوکس شما

iptables -A PREROUTING -t nat -s 192.168.50.0/24 -p tcp --dport 80 -j REDIRECT --to-port 3128

فایل squid.conf به شرح زیر تغییر بدید

### Squid normally listens to port 3128
http_port 3128 transparent

### Recommended minimum configuration
acl manager proto cache_object
acl localhost src 127.0.0.1/32
acl to_localhost dst 127.0.0.0/8


### Access Control List
acl users src 192.168.50.0/24

### Recommended minimum Access Permission configuration
# Only allow cachemgr access from localhost
http_access allow users
http_access allow manager localhost
http_reply_access allow all

### LOGS
access_log /var/log/squid/access.log squid

حالا با دستور زیر میتونید ترافیک عبوری از سرور Squid خودتونو ببینید

tail -f /var/log/squid/access.log

squid analyzer در IBSng رو اجرا و حالت Auto رو انتخاب کنید

usr/local/IBSng/addons/squid_analyzer/setup.sh

نکته :

اگر به صورت Auto اجرا نشد از حالت دستی استفاده کنید

cd /usr/local/IBSng/addons/squid_analyzer/
cp init.d/squid_analyzer /etc/init.d
chkconfig --add squid_analyzer
chkconfig squid_analyzer on
cd /usr/local/IBSng/addons/squid_analyzer/logrotate.d
cp squid /etc/logrotate.d
cp squid_analyzer /etc/logrotate.d

حالا سرویس های مورد نظر را استارت کنید

/etc/init.d/squid_analyzer start
/etc/init.d/squid start

حتما این ip forward در لینوکس رو روشن کنید

echo 1  /proc/sys/net/ipv4/ip_forward
5پسند
884بازدید

ممكن است این موارد را هم بپسندید!

۲۵ پاسخ

  • حسن علی زاده۰۷/۰۷/۱۳۹۵ در ۰۸:۱۴

    با سلام
    ضمن تشکر از آموزش شما استاد عزیز
    در هنگام اجرای دستور iptables -A PREROUTING -t nat -s 192.168.50.0/24 -p tcp –dport 80 -j REDIRECT –to-port 3128 در قسمت قوانین iptables با خطای زیر مواجه می شوم لطفا راهنمایی بفرمایید. ممنون
    iptables -A PREROUTING -t nat -s 192.168.50.0/24 -p tcp –d p ort 80 -j REDIRECT –to-port 3128

    Bad argument `–d’
    Try `iptables -h’ or ‘iptables –help’ for more information.

    پاسخ دادن
    • مرتضی منافی۰۹/۰۷/۱۳۹۵ در ۱۹:۰۲

      سلام اصلاح شد

      iptables -A PREROUTING -t nat -s 192.168.50.0/24 -p tcp --dport 80 -j REDIRECT --to-port 3128

      پاسخ دادن
  • اشکان سلیمی۱۲/۰۷/۱۳۹۵ در ۲۰:۲۷

    با سلام
    ممنون از آموزش خوبتان
    یه سوال داشتم کاربران ما از طریق pptp و یوزری که در IBS تعریف شده لاگین می کنن. می خواستم بپرسم چطوری می تونم وب آنالایزر را برای کاربران pptp فعال کنیم آیا آیا در قسمت منگل باید آی پی ها vpn مارک روت شوند یا به شکل دیگر؟ ممنون میشم به شکل شفاف تر راهنمایی کنید باز هم از وقتی که برای این آموزش گذاشتین کمال تشکر را دارم.(به عنوان مثال آی پی PC ها ۱۹۲.۱۶۸.۵۰.۰/۲۴ و vpn pool هم ۲۵۰.۱.۱.۲۴۰-۲۵۰.۱.۱.۱۰ هست. بقیه سناریو همانند توصیفات شماست.)

    پاسخ دادن
    • مرتضی منافی۱۴/۰۷/۱۳۹۵ در ۱۲:۴۸

      سلام
      فرقی نمی کنه از چه پروتکلی برای اتصال به میکروتیک استفاده می کنید
      فقط در قسمت منگل باید لیست IP های که سرویس دهنده هیتند مارک روت شوند

      پاسخ دادن
  • علی۱۶/۰۷/۱۳۹۵ در ۱۳:۴۳

    سلام
    چرا وقتی من این کانفیگ رو انجام میدم هیچ لاگی در فایل access.log اسکویید نیست حتی وب آنالایزر رو می زنم هیچی نمی آره؟
    خواهش می کنم راهنمایی کنید. با تشکر

    پاسخ دادن
    • مرتضی منافی۱۶/۰۷/۱۳۹۵ در ۱۶:۴۱

      سلام
      دوست عزیز اگر Mark Mangel , Router درست انجام داده باشید باید بیاد

      پاسخ دادن
      • امیر۲۹/۰۸/۱۳۹۵ در ۱۶:۲۳

        سلام من دستوراتی که نوشتید انجام دادم لاگ هم میگیره فایل var/log/squid/access.log چک کردم ولی تو ibs قسمت Web Analyzer Logs هیچی نشون نمیده باید چی کار کرد ؟
        ممنون میشم راهنمایی کنید

        پاسخ دادن
        • مرتضی منافی۲۰/۰۴/۱۳۹۶ در ۰۹:۵۶

          سلام ی دسترسی به ایمیل بنده بزنید

          پاسخ دادن
  • بهروز۲۹/۰۷/۱۳۹۵ در ۱۷:۱۴

    با سلام من اینکارها رو انجام دادم ولی نمی دونم چرا توی اسکویید هیچ لاگی نمی افته. لطفا اگه امکان داره یک شکلی از شبکه مورد نظر بکشید که موقعیت سرورها به هم مشخص بشن.
    ۱- آیا تنظیمات مربوط به میکروتیک همین ها هستن یا برای تعیین هویت بایستی کارای اضافه تر انجام داد؟
    ۲- در این مثال شما از چه IP Pool استفاده می کنید؟
    ۳- آیا اگر فایروال لینوکس را غیرفعال کنیم باز لازمه که دستورات مربوط به iptable ها نوشته بشه؟
    ممنون میشم منو از ابهام دربیارین. از وقتی که برای آموزش گذاشتین سپاسگزارم.

    پاسخ دادن
    • مرتضی منافی۲۰/۰۴/۱۳۹۶ در ۱۰:۱۱

      سلام با این روش تیت کنید برای انتقال لاگ به لینوکس از روتر دستور زیر رو داخل ترمینال میکروتیک وارد می کنیم
      نکته : در بخش client’s_used subnet از رنج IP که کاربران استفاده می کنند و squid_address بخش IP اسکوید را وارد کنید .

      ip firewall nat add action=dst-nat dst-port=80 protocol=tcp src-address="client's_used subnet" to-addresses="squid_address" to-ports=8080 chain=dstnat
      ۲. هر چی خودتون استفاده کردید
      ۳.نه نیازی نیست تو کامند های بالا فایوال باز شده اما نیاز بود غیرفعال کنید

      پاسخ دادن
      • احسان۰۳/۰۵/۱۳۹۶ در ۰۹:۰۴

        ببخشید چرا to-ports=8080 ؟؟؟؟

        پاسخ دادن
  • مجتبی۰۵/۰۹/۱۳۹۵ در ۲۰:۴۰

    با سلام . طریقه نصب در نسخه دبیان ibs رو هم منتشر کنید .. ممنون

    پاسخ دادن
    • مرتضی منافی۲۰/۱۱/۱۳۹۵ در ۱۳:۰۴

      سلام
      زیاد تفاوت نداره دستور لینوکسش یکم تفاوت داره

      پاسخ دادن
      • کیوان۱۱/۰۳/۱۳۹۶ در ۱۵:۵۴

        با عرض سلام لطفا در صورت امکان نحوه راه اندازی ibsng در حالت poptop رو توضیح دهید. ممنون میشم.

        پاسخ دادن
        • مرتضی منافی۱۹/۰۴/۱۳۹۶ در ۲۰:۳۲

          سلام حتما بر روی چشم

          پاسخ دادن
  • مهدی اسماعیلی۱۰/۰۹/۱۳۹۵ در ۰۹:۴۴

    درود استاد..من این کانفیگو انجام دادم…ولی خوب توی IBSng هیچ لاگی نشون نمیده..سرویس squid استارت میشه ولی web_anlyze استارت نمیشه

    پاسخ دادن
    • مرتضی منافی۲۰/۰۴/۱۳۹۶ در ۰۹:۵۶

      سلام ی دسترسی به ایمیل بنده بزنید

      پاسخ دادن
  • مهدی۱۰/۰۹/۱۳۹۵ در ۱۷:۱۷

    سلام..من تمام این کانفیگا رو انجام دادم…سرویس squid استارت میشه وبی squid_anlyzer وقتی میخوای استارتش کنی میگه از قبل استارت هست..به هیچ وجه stop یا ریستارت نمیشه ..نمیدونم مشکل داره یا دیفالتش اینجوری هست…با این تفاسیر اصلا در ibsng هیچ لاگی نمایش داده نمیشه…ممنون میشم راهنمایی کنید

    پاسخ دادن
    • مرتضی منافی۲۰/۰۴/۱۳۹۶ در ۰۹:۵۶

      سلام ی دسترسی به ایمیل بنده بزنید

      پاسخ دادن
  • احسان۱۹/۰۴/۱۳۹۶ در ۱۱:۵۶

    با سلام
    لین پست کامل نیست !!!!!!!!!!!!!!
    و مطب به این دلیل در سایت پست شده که آماری برای بازدید وب سایت و همچنین معرفی نرم افزار NTM باشه
    دوستان کلا از طرف ادمین سایت سر کار رفته ایید

    پاسخ دادن
    • مرتضی منافی۱۹/۰۴/۱۳۹۶ در ۲۰:۳۰

      سلام شما بلدی ایراد بگیر حلش کنیم
      کدوم مطلب ما برای افزایش بازدید بوده این دومیش باشه

      پاسخ دادن
      • احسان۲۵/۰۴/۱۳۹۶ در ۱۱:۱۹

        شما که استاد هستی یک آموزش تصویری صفر تا صد رو برای کابرها تهیه کن که دوستان مطمئن باشن که همه توضیحات شما کامل و بدون نقص می باشد
        همین مطلب شما برای بالا بردن آمار بازدید سایت پست شده

        پاسخ دادن
        • مرتضی منافی۲۵/۰۴/۱۳۹۶ در ۱۶:۲۲

          کل ابنترنت رو بگردی در همین حد آموزش هم پیدا نمی کنی
          اگه مشکلی باگی در اموزش میبینی بفرماید با کمال میل و با دکر منبع به نام شما اصلاح کنیم
          کسی که تخصص کافی در ضمینه شبکه رو داره با همین اموزش دیگه نیازی به فیلم اموزشی نداره
          متاسفانه وقت این کار رو ندارم با عرض پوزش

          پاسخ دادن
  • محسن۱۱/۰۷/۱۳۹۶ در ۱۲:۲۹

    با سلام و خسته نباشید
    بابت توضیحاتتون ممنون
    ممنون میشم اگه یه آموزش تصویری بزارید چون واقعا من همه کارهارو کردم و لی نتونستم جواب بگیرم

    پاسخ دادن
    • مرتضی منافی۱۲/۰۹/۱۳۹۶ در ۱۲:۵۹

      سلام دسترسی بدید براتون چکش کنم

      پاسخ دادن

ارسال دیدگاه

لطفا نام خود را وارد كنید! لطفا آدرس ایمیل را صحیح وارد كنید! لطفا پیام را وارد كنید!